Use notebooks

You use Databricks notebooks to develop data science and machine learning workflows and to collaborate with colleagues across engineering, data science, machine learning, and BI teams. Databricks notebooks provide real-time coauthoring and automated versioning.

You can work in Databricks notebooks using Python, SQL, Scala, and R and customize your environment with the libraries of your choice. Databricks notebooks also provide built-in data visualizations and automatic versioning. You can schedule notebooks to automatically run workflows. You can export results and notebooks in .html or .ipynb format, and build and share dashboards.

Configure notebook settings

To configure notebook settings, select User Settings Icon > User Settings > Notebook Settings.

Develop in notebooks

Notebooks use two types of cells: code cells and markdown cells. Code cells contain runnable code. Markdown cells contain markdown code that renders into text and graphics when the cell is executed. You can run each cell individually or run the whole notebook at once.

The notebook toolbar includes menus and icons that you can use to manage and edit the notebook.

Notebook toolbar

Next to the notebook name are buttons that let you change the default language of the notebook and, if the notebook is included in a Databricks Repo, open the Git dialog.

To view previous versions of the notebook, click the “Last edit…” message to the right of the menus.

The icons at the right are described in the following table:

Icon

Description

Notebook header experiment icon

Open MLflow notebook experiment.

Notebook header comments icon

Open notebook comments.

Notebook header cluster selector

Open cluster selector. The name of this button changes depending on the notebook and cluster state.

Notebook header job scheduler

Open job scheduler.

Notebook header share button

Open permissions dialog.

The cell actions Cell actions menu lets you cut, copy, and paste cells, move cells around in the notebook, add a title to the cell, and hide code or results.

Cell actions menu

From this menu you can also run code cells:

Cell actions menu - run

Menu items to hide a cell Cell Minimize or delete a cell Delete Icon also appear.

For Markdown cells, an option to add the cell to a dashboard appears. For more information, see Dashboards.

Dashboard

Keyboard shortcuts

To display keyboard shortcuts, select Help > Keyboard shortcuts. The keyboard shortcuts available depend on whether the cursor is in a code cell (edit mode) or not (command mode).

Work with cells

When you delete a cell, by default a delete confirmation dialog appears. To disable future confirmation dialogs, select the Do not show this again checkbox and click Confirm. You can also toggle the confirmation dialog setting with the Turn on command delete confirmation option in user settings.

Important

The maximum size for a notebook cell, both contents and output, is 16MB.

Create, cut, copy, and paste cells

To create a new cell, hover over a cell at the top or bottom and click the Add Cell icon. You can also use the notebook cell menu: click Down Caret and select Add Cell Above or Add Cell Below.

There are several options to cut and copy cells:

  • Use the cell actions menu Cell actions at the right of the cell. Click Down Caret and select Cut Cell or Copy Cell.

  • Use keyboard shortcuts: Command-X or Ctrl-X to cut and Command-C or Ctrl-C to copy.

  • Use the Edit menu at the top of the notebook. Select Cut or Copy.

After you cut or copy cells, you can paste those cells elsewhere in the notebook, into a different notebook, or into a notebook in a different browser tab or window. To paste cells, use the keyboard shortcut Command-V or Ctrl-V. The cells are pasted below the current cell.

You can use the keyboard shortcut Command-Z or Ctrl-Z to undo cut or paste actions.

Note

If you are using Safari, you must use the keyboard shortcuts.

  • To cut and paste a cell, click Down Caret from the cell actions menu and select Cut Cell. Then, select Paste Above or Paste Below from the cell actions menu of another cell.

    You can restore cut cells using Edit > Undo Cut Cells.

  • To select adjacent cells, click in a Markdown cell and then use Shift + Up or Down to select the cells above or below it. Use the edit menu to copy, cut, paste, or delete the selected cells as a group. To select all cells, select Edit > Select All Cells or use the command mode shortcut Cmd+A.

Set default language

The default language for the notebook appears next to the notebook name.

Notebook default language

To change the default language, click the language button and select the new language from the dropdown menu. To ensure that existing commands continue to work, commands of the previous default language are automatically prefixed with a language magic command.

Mix languages

By default, cells use the default language of the notebook. You can override the default language in a cell by clicking the language button and selecting a language from the dropdown menu.

Cell language drop down

Alternately, you can use the language magic command %<language> at the beginning of a cell. The supported magic commands are: %python, %r, %scala, and %sql.

Note

When you invoke a language magic command, the command is dispatched to the REPL in the execution context for the notebook. Variables defined in one language (and hence in the REPL for that language) are not available in the REPL of another language. REPLs can share state only through external resources such as files in DBFS or objects in object storage.

Notebooks also support a few auxiliary magic commands:

  • %sh: Allows you to run shell code in your notebook. To fail the cell if the shell command has a non-zero exit status, add the -e option. This command runs only on the Apache Spark driver, and not the workers. To run a shell command on all nodes, use an init script.

  • %fs: Allows you to use dbutils filesystem commands. For example, to run the dbutils.fs.ls command to list files, you can specify %fs ls instead. For more information, see How to work with files on Databricks.

  • %md: Allows you to include various types of documentation, including text, images, and mathematical formulas and equations. See the next section.

Explore SQL cell results in Python notebooks natively using Python

You might want to load data using SQL and explore it using Python. In a Databricks Python notebook, table results from a SQL language cell are automatically made available as a Python DataFrame. The name of the Python DataFrame is _sqldf.

Note

  • In Python notebooks, the DataFrame _sqldf is not saved automatically and is replaced with the results of the most recent SQL cell run. To save the DataFrame, run this code in a Python cell:

    new_dataframe_name = _sqldf
    
  • If the query uses a widget for parameterization, the results are not available as a Python DataFrame.

  • If the query uses the keywords CACHE TABLE or UNCACHE TABLE, the results are not available as a Python DataFrame.

The screenshot shows an example:

sql results dataframe

SQL syntax highlighting and autocomplete in Python commands

Syntax highlighting and SQL autocomplete are available when you use SQL inside a Python command, such as in a spark.sql command.

Document your code

You can create markdown cells to document your code, either by selecting Markdown from the cell’s language button or by using the %md magic command. The contents of the cell are rendered into HTML. For example, this snippet contains markup for a level-one heading:

%md # Hello This is a Title

It is rendered as a HTML title:

Notebook HTML title

Collapsible headings

Cells that appear after cells containing Markdown headings can be collapsed into the heading cell. The following image shows a level-one heading called Heading 1 with the following two cells collapsed into it.

Collapsed cells

To expand and collapse headings, click the + and -.

Also see Hide and show cell content.

To expand or collapse cells after cells containing Markdown headings throughout the notebook, select Expland all headings or Collapse all headings from the View menu.

expand-collapse all in the view menu

Display images

To display images stored in the FileStore, use the syntax:

%md
![test](files/image.png)

For example, suppose you have the Databricks logo image file in FileStore:

dbfs ls dbfs:/FileStore/
databricks-logo-mobile.png

When you include the following code in a Markdown cell:

Image in Markdown cell

the image is rendered in the cell:

Rendered image

Display mathematical equations

Notebooks support KaTeX for displaying mathematical formulas and equations. For example,

%md
\\(c = \\pm\\sqrt{a^2 + b^2} \\)

\\(A{_i}{_j}=B{_i}{_j}\\)

$$c = \\pm\\sqrt{a^2 + b^2}$$

\\[A{_i}{_j}=B{_i}{_j}\\]

renders as:

Rendered equation 1

and

%md
\\( f(\beta)= -Y_t^T X_t \beta + \sum log( 1+{e}^{X_t\bullet\beta}) + \frac{1}{2}\delta^t S_t^{-1}\delta\\)

where \\(\delta=(\beta - \mu_{t-1})\\)

renders as:

Rendered equation 2

Include HTML

You can include HTML in a notebook by using the function displayHTML. See HTML, D3, and SVG in notebooks for an example of how to do this.

Note

The displayHTML iframe is served from the domain databricksusercontent.com and the iframe sandbox includes the allow-same-origin attribute. databricksusercontent.com must be accessible from your browser. If it is currently blocked by your corporate network, it must added to an allow list.

Command comments

You can have discussions with collaborators using command comments.

To toggle the Comments sidebar, click the Comments button at the top right of a notebook.

Toggle notebook comments

To add a comment to a command:

  1. Highlight the command text and click the comment bubble:

    Open comments
  2. Add your comment and click Comment.

    Add commenty

To edit, delete, or reply to a comment, click the comment and choose an action.

Edit comment

Change cell display

There are three display options for notebooks:

  • Standard view: results are displayed immediately after code cells.

  • Results only: only results are displayed.

  • Side-by-side: code and results cells are displayed side by side.

Use the View menu View Menu to select a display option.

Show line and command numbers

To show line numbers or command numbers, go to the View menu View Menu and select Show line numbers or Show command numbers. Once they’re displayed, you can hide them again from the same menu. You can also enable line numbers with the keyboard shortcut Control+L.

Show line or command numbers via the view menu
Line and command numbers enabled in notebook

If you enable line or command numbers, Databricks saves your preference and shows them in all of your other notebooks for that browser.

Command numbers above cells link to that specific command. If you click the command number for a cell, it updates your URL to be anchored to that command. If you want to link to a specific command in your notebook, right-click the command number and choose copy link address.

Find and replace text

To find and replace text within a notebook, select Edit > Find and Replace. The current match is highlighted in orange and all other matches are highlighted in yellow.

Matching text

To replace the current match, click Replace. To replace all matches in the notebook, click Replace All.

To move between matches, click the Prev and Next buttons. You can also press shift+enter and enter to go to the previous and next matches, respectively.

To close the find and replace tool, click Delete Icon or press esc.

Autocomplete

You can use Databricks autocomplete to automatically complete code segments as you type them. Databricks supports two types of autocomplete: local and server.

Local autocomplete completes words that are defined in the notebook. Server autocomplete accesses the cluster for defined types, classes, and objects, as well as SQL database and table names. To activate server autocomplete, attach your notebook to a cluster and run all cells that define completable objects.

Important

Server autocomplete in R notebooks is blocked during command execution.

To trigger autocomplete, press Tab after entering a completable object. For example, after you define and run the cells containing the definitions of MyClass and instance, the methods of instance are completable, and a list of valid completions displays when you press Tab.

Trigger autocomplete

SQL database and table name completion, type completion, syntax highlighting and SQL autocomplete are available in SQL cells and when you use SQL inside a Python command, such as in a spark.sql command.

Type Completion — — SQL Completion

In Databricks Runtime 7.4 and above, you can display Python docstring hints by pressing Shift+Tab after entering a completable Python object. The docstrings contain the same information as the help() function for an object.

Python docstring

Format SQL

Databricks provides tools that allow you to format SQL code in notebook cells quickly and easily. These tools reduce the effort to keep your code formatted and help to enforce the same coding standards across your notebooks.

You can trigger the formatter in the following ways:

  • Single cells

    • Keyboard shortcut: Press Cmd+Shift+F.

    • Command context menu: Select Format SQL in the command context dropdown menu of a SQL cell. This item is visible only in SQL notebook cells and those with a %sql language magic.

      Formatting SQL From Command Context
  • Multiple cells

    Select multiple SQL cells and then select Edit > Format SQL Cells. If you select cells of more than one language, only SQL cells are formatted. This includes those that use %sql.

    Formatting SQL From Edit Menu

Here’s the first cell in the preceding example after formatting:

After Formatting SQL

View table of contents

To display an automatically generated table of contents, click the arrow at the upper left of the notebook (between the sidebar and the topmost cell). The table of contents is generated from the Markdown headings used in the notebook.

Open TOC

To close the table of contents, click the left-facing arrow.

Close TOC

View notebooks in dark mode

You can choose to display notebooks in dark mode. To turn dark mode on or off, select View > Notebook Theme and select Light Theme or Dark Theme.

Notebook light or dark mode

Run notebooks

Before you can run any cell in a notebook, you must attach the notebook to a cluster.

To run all the cells in a notebook, select Run All in the notebook toolbar.

Important

Do not use Run All if steps for mount and unmount are in the same notebook. It could lead to a race condition and possibly corrupt the mount points.

To run a single cell, click in the cell and press shift+enter.

To run all cells before or after a cell, use the cell actions menu Cell actions at the far right. Click Run Menu and select Run All Above or Run All Below. Run All Below includes the cell you are in; Run All Above does not.

When a notebook is running, the icon in the notebook tab changes from notebook tab icon to running notebook tab icon. If notifications are enabled in your browser and you navigate to a different tab while a notebook is running, a notification appears when the notebook finishes.

Attach a notebook to a cluster

To attach a notebook to a cluster, you need the Can Attach To cluster-level permission.

Important

As long as a notebook is attached to a cluster, any user with the Can Run permission on the notebook has implicit permission to access the cluster.

To attach a notebook to a cluster, click the cluster selector in the notebook toolbar and select a cluster from the dropdown menu. The menu shows a selection of clusters that you have used recently or that are currently running.

Attach notebook

To select from all available clusters, click More… and select an existing cluster from the dropdown menu in the dialog.

more clusters dialog

You can also create a new cluster by selecting Create new resource… from the dropdown menu.

Important

An attached notebook has the following Apache Spark variables defined.

Class

Variable Name

SparkContext

sc

SQLContext/HiveContext

sqlContext

SparkSession (Spark 2.x)

spark

Do not create a SparkSession, SparkContext, or SQLContext. Doing so will lead to inconsistent behavior.

Detach a notebook from a cluster

To detach a notebook from a cluster, click the cluster selector in the notebook toolbar and hover over the attached cluster in the list to display a side menu. From the side menu, select Detach.

Detach notebook

You can also detach notebooks from a cluster using the Notebooks tab on the cluster details page.

When you detach a notebook from a cluster, the execution context is removed and all computed variable values are cleared from the notebook.

Tip

Databricks recommends that you detach unused notebooks from a cluster. This frees up memory space on the driver.

View multiple outputs per cell

Python notebooks and %python cells in non-Python notebooks support multiple outputs per cell.

Multiple outputs in one cell

In Databricks Runtime 7.3 LTS, you must enable this feature by setting spark.databricks.workspace.multipleResults.enabled true.

Python and Scala error highlighting

Python and Scala notebooks support error highlighting. That is, the line of code that is throwing the error will be highlighted in the cell. Additionally, if the error output is a stacktrace, the cell in which the error is thrown is displayed in the stacktrace as a link to the cell. You can click this link to jump to the offending code.

Python error highlighting
Scala error highlighting

Notifications

Notifications alert you to certain events, such as which command is currently running during Run notebooks and which commands are in error state. When your notebook is showing multiple error notifications, the first one will have a link that allows you to clear all notifications.

Notebook notifications

Notebook notifications are enabled by default. You can disable them in user settings.

Background notifications

If you start a notebook run and then navigate away from the tab or window that the notebook is running in, a notification appears when the notebook is completed. You can disable this notification in your browser settings.

Databricks Advisor

Databricks Advisor automatically analyzes commands every time they are run and displays appropriate advice in the notebooks. The advice notices provide information that can assist you in improving the performance of workloads, reducing costs, and avoiding common mistakes.

View advice

A blue box with a lightbulb icon signals that advice is available for a command. The box displays the number of distinct pieces of advice.

Databricks advice

Click the lightbulb to expand the box and view the advice. One or more pieces of advice will become visible.

View advice

Click the Learn more link to view documentation providing more information related to the advice.

Click the Don’t show me this again link to hide the piece of advice. The advice of this type will no longer be displayed. This action can be reversed in Notebook Settings.

Click the lightbulb again to collapse the advice box.

Advice settings

To enable or disable Databricks Advisor, go to user settings or click the gear icon in the expanded advice box.

Notebook settings

Toggle the Turn on Databricks Advisor option to enable or disable advice.

The Reset hidden advice link is displayed if one or more types of advice is currently hidden. Click the link to make that advice type visible again.

Share code in notebooks

Databricks supports several methods for sharing code among notebooks. Each of these permits you to modularize and share code in a notebook, just as you would with a library.

For more complex interactions between notebooks, see Modularize or link code in notebooks.

Use %run to import a notebook

The %run magic executes all of the commands from another notebook. A typical use is to define helper functions in one notebook that are used by other notebooks.

In the example below, the first notebook defines a helper function, reverse, which is available in the second notebook after you use the %run magic to execute shared-code-notebook.

Shared code notebook
Notebook import example

Because both of these notebooks are in the same directory in the workspace, use the prefix ./ in ./shared-code-notebook to indicate that the path should be resolved relative to the currently running notebook. You can organize notebooks into directories, such as %run ./dir/notebook, or use an absolute path like %run /Users/username@organization.com/directory/notebook.

Note

  • %run must be in a cell by itself, because it runs the entire notebook inline.

  • You cannot use %run to run a Python file and import the entities defined in that file into a notebook. To import from a Python file, see Reference source code files using git. Or, package the file into a Python library, create a Databricks library from that Python library, and install the library into the cluster you use to run your notebook.

  • When you use %run to run a notebook that contains widgets, by default the specified notebook runs with the widget’s default values. You can also pass in values to widgets; see Use Databricks widgets with %run.

Reference source code files using git

Preview

This feature is in Public Preview.

For notebooks stored in a Databricks Repo, you can reference source code files in the repository. The following example uses a Python file rather than a notebook.

Create a new example repo to show the file layout:

New repo
Example repo

To configure an existing Git repository, see Clone a remote Git repository.

Create two files in the repo:

  1. A Python file with the shared code.

  2. A notebook that uses the shared Python code.

Shared code repo files

The Python file shared.py contains the helper.

Shared code Python file

Now, when you open the notebook, you can reference source code files in the repository using common commands like import.

Shared code git file

For more information on working with files in Git repositories, see Work with files in the UI.

Manage notebook state and outputs

After you attach a notebook to a cluster and run one or more cells, your notebook has state and displays outputs. This section describes how to manage notebook state and outputs.

Clear notebooks state and outputs

To clear the notebook state and outputs, select one of the Clear options at the bottom of the Run menu.

Clear state and outputs

Show results

When a cell is run, Databricks returns 1000 rows of a DataFrame. With Databricks Runtime 8.4 and above, if there are more than 1000 rows, you can re-execute the query to show up to 10,000 rows.

Option to re-run

Download results

By default downloading results is enabled. To toggle this setting, see Manage the ability to download results from notebooks.

You can download a cell result that contains tabular output to your local machine. Click the three-button menu next to the tab title. The menu options depend on the number of rows in the result and on the Databricks Runtime version. Downloaded results are saved on your local machine as a CSV file named export.csv.

Download cell results

Hide and show cell content

Cell content consists of cell code and the result of running the cell. You can hide and show the cell code and result using the cell actions menu Cell actions at the top right of the cell.

To hide cell code:

  • Click Down Caret and select Hide Code

To hide and show the cell result, do any of the following:

  • Click Down Caret and select Hide Result

  • Select Cell Minimize

  • Type Esc > Shift + o

To show hidden cell code or results, click the Show links:

Show hidden code and results

See also Collapsible headings.

Notebook isolation

Notebook isolation refers to the visibility of variables and classes between notebooks. Databricks supports two types of isolation:

  • Variable and class isolation

  • Spark session isolation

Note

Since all notebooks attached to the same cluster execute on the same cluster VMs, even with Spark session isolation enabled there is no guaranteed user isolation within a cluster.

Variable and class isolation

Variables and classes are available only in the current notebook. For example, two notebooks attached to the same cluster can define variables and classes with the same name, but these objects are distinct.

To define a class that is visible to all notebooks attached to the same cluster, define the class in a package cell. Then you can access the class by using its fully qualified name, which is the same as accessing a class in an attached Scala or Java library.

Spark session isolation

Every notebook attached to a cluster running Apache Spark 2.0.0 and above has a pre-defined variable named spark that represents a SparkSession. SparkSession is the entry point for using Spark APIs as well as setting runtime configurations.

Spark session isolation is enabled by default. You can also use global temporary views to share temporary views across notebooks. See CREATE VIEW. To disable Spark session isolation, set spark.databricks.session.share to true in the Spark configuration.

Important

Setting spark.databricks.session.share true breaks the monitoring used by both streaming notebook cells and streaming jobs. Specifically:

  • The graphs in streaming cells are not displayed.

  • Jobs do not block as long as a stream is running (they just finish “successfully”, stopping the stream).

  • Streams in jobs are not monitored for termination. Instead you must manually call awaitTermination().

  • Calling the Create a new visualization on streaming DataFrames doesn’t work.

Cells that trigger commands in other languages (that is, cells using %scala, %python, %r, and %sql) and cells that include other notebooks (that is, cells using %run) are part of the current notebook. Thus, these cells are in the same session as other notebook cells. By contrast, a notebook workflow runs a notebook with an isolated SparkSession, which means temporary views defined in such a notebook are not visible in other notebooks.

Version history

Databricks notebooks maintain a history of notebook versions, allowing you to view and restore previous snapshots of the notebook. You can perform the following actions on versions: add comments, restore and delete versions, and clear version history.

To access notebook versions, click the “Last edit…” message in the toolbar. The notebook versions appear at the right side of the browser tab. You can also select File > Version history.

Add a comment

To add a comment to the latest version:

  1. Click the version.

  2. Click Save now.

    Save comment
  3. In the Save Notebook Revision dialog, enter a comment.

  4. Click Save. The notebook version is saved with the entered comment.

Restore a version

To restore a version:

  1. Click the version.

  2. Click Restore this revision.

    Restore revision
  3. Click Confirm. The selected version becomes the latest version of the notebook.

Delete a version

To delete a notebook’s version entry:

  1. Click the version.

  2. Click the trash icon Trash.

    Delete revision
  3. Click Yes, erase. The selected version is deleted from the history.

Clear version history

To clear the version history for a notebook:

  1. Select File > Clear version history.

  2. Click Yes, clear. The notebook version history is cleared.

    Warning

    The version history cannot be recovered after it has been cleared.

Version control with Git

Note

To sync your work in Databricks with a remote Git repository, Databricks recommends using Git integration with Databricks Repos.

To link a single notebook to Git, Databricks also supports these Git-based version control tools:

GitHub version control

Bitbucket Cloud and Bitbucket Server version control

Test notebooks

This section covers several ways to test code in Databricks notebooks. You can use these methods separately or together.

Many unit testing libraries work directly within the notebook. For example, you can use the built-in Python `unittest` package to test notebook code.

def reverse(s):
    return s[::-1]

import unittest

class TestHelpers(unittest.TestCase):
    def test_reverse(self):
        self.assertEqual(reverse('abc'), 'cba')

r = unittest.main(argv=[''], verbosity=2, exit=False)
assert r.result.wasSuccessful(), 'Test failed; see logs above'

Test failures appear in the output area of the cell.

Unit test failure

You can use widgets to distinguish test invocations from normal invocations in a single notebook.

Widget customize execution

To hide test code and results, select the associated menu items from the cell dropdown menu. Any errors that occur appear even when results are hidden.

Hiding test code and results

To run tests periodically and automatically, you can use scheduled notebooks. You can configure the job to send notification emails to an address you specify.

Scheduled notebook test

Separate test code from the notebook

To separate your test code from the code being tested, see Share code in notebooks.

An example using %run:

Separating test code

For code stored in a Databricks Repo, you can use the web terminal to run tests in source code files just as you would on your local machine.

Repos testing invocation

You can also run this test from a notebook.

Notebook testing invocation

For notebooks in a Databricks Repo, you can set up a CI/CD-style workflow by configuring notebook tests to run for each commit. See Databricks GitHub Actions.